Expansion Image Missing

  • Got a weird one today, one of my expansions refuses to export the image.


    I've tried:

    • Using different versions of the same image (doesn't work).
    • Using the same image file in a different expansion folder (works).
    • Using other expansion images in this expansion folder (works).
    • Using a new version of the image with a new name (doesn't work).
    • Deleting the .hxi file of the expansion and re-encoding (doesn't work).

    The image is formatted the same as other expansions, same dimensions and similar file size. But I just can't get it to work in the exported plugin. I'm sure it's something dumb that I've forgotten to do, as it's been a while since I've exported an expansion.

    Master branch.

  • @iamlamprey what is the name of your image? I remember having a hard time figuring out an exporting issue, it was because the name contained the word "system" in it and made the exporter become crazy... But it might not be related

  • @ustk The image name format is "bg_expansion.png" and this particular one is "bg_Oracle2.png", but all the other ones export just fine, which is why it's so confusing

            //Setting BG Image           
        backgroundImage = ("{EXP::Oracle2}bg_Oracle2.png");        
        Image_BG.set("fileName", backgroundImage);     

    I've just copy-pasted this from the other expansion loading callbacks and changed the file name string, and it's worked every other time except for this one, like it's cursed or something 😂

    If I move an image from another expansion and export it/call that, it works perfectly, so confusing

  • Still can't get this working, has anyone else experienced missing images like this?

  • @iamlamprey Have you tried to change the name?

  • Does the image show up in HISE's file browser in the sampler workspace when you select the expansion?

  • @ustk @d-healey So I opened it in the sampler workspace and the name was in all lowercase, I think I messed up my naming conventions somewhere down the line and didn't realize it - seems to be fixed now

    Cheers 🙂

Log in to reply