VST Export Error: The System Cannot Find the Path Specified



  • I recompiled HISE yesterday to the Scriptnode branch, and today, none of my exports are working. It says the system cannot find the path specified; however, I have it set correctly to the HISE root directory within the preferences.

    I have visual studio 2017 and 2019 installed, but the latter did not cause issues before.



  • @Confuzzled Which path is it looking for?



  • Not entirely sure at this point.

    Finished saving: Visual Studio 2017
    Finished saving: Xcode (MacOSX)
    Finished saving: Xcode (iOS)
    Finished saving: Linux Makefile
    Compiling 64bit Instrument plugin Oboe QuickTest ...
    The system cannot find the path specified.
    Press any key to continue . . .



  • Try deleting the binaries folder and re-exporting



  • Same error.





  • That's what I initially thought as well, but it says it is using Visual Studio 2017.



  • @Confuzzled Open the .jucer file that was generated by the export, this will be in the binaries folder. When it opens in Projucer go to File >> Open in IDE, and make sure it opens VS2017, try exporting it directly from VS2017. If it works then it probably means the error is due to having both versions installed and the automated system is picking the wrong one.



  • It was able to build via this method, so there may be a problem with having multiple VS versions installed. Unfortunately, I need 2019 for other things.

    Furthermore, the newer version of IPP appears to still be problematic... After all that time and when I finally believed to have gotten IPP working.

    With ipp enabled:

    1>...\hise-scriptnode\hi_streaming\hi_streaming.h(69): fatal error C1083: Cannot open include file: 'ipp.h': No such file or directory (compiling source file ....\JuceLibraryCode\include_stk_wrapper.cpp)
    1>Done building project "Oboe QuickTest_SharedCode.vcxproj" -- FAILED.
    2>------ Build started: Project: Oboe QuickTest_VST, Configuration: Release x64 ------
    2>include_juce_audio_plugin_client_VST2.cpp
    2>LINK : fatal error LNK1181: cannot open input file 'Oboe QuickTest x64.lib'
    2>Done building project "Oboe QuickTest_VST.vcxproj" -- FAILED.

    With Ipp Disabled:

    2>...\hise-scriptnode\juce\modules\juce_core\text\juce_charpointer_ascii.h(43): warning C4702: unreachable code
    2>Finished generating code
    2>Oboe QuickTest_VST.vcxproj -> ...\Oboe Sample Library_POC\HISE Project\Binaries\Builds\VisualStudio2017.....\Compiled\VST\Oboe QuickTest x64.dll
    2>Done building project "Oboe QuickTest_VST.vcxproj".
    ========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ==========

    Luckily, I dont use internal reverbs in anything I make; however, I did run into an odd quirk when I loaded the vst.

    It kept asking for a .hr1 archive file, but it doesnt appear to have ever made one. Everything turns up blank when doing a system-wide search. I'm assuming this is because I am redirecting the samples to another folder. But it appears to have worked after just telling to physically look at said folder.

    For me, it isnt a big deal at the moment, but is this intended? This is the first time I have tried working with HISE where all of my assets are not in the root project hierarchy.



  • @Confuzzled

    No-one seems to have had success with the latest version of IPP.

    It kept asking for a .hr1 archive file, but it doesnt appear to have ever made one.

    If you want to use the .hr format you have to export your samples from HISE in that format - Export >> Export samples for installer



  • @d-healey Good to know about the .hr format!

    I just tried building a few other things. It does look like the automated system is hit or miss at choosing to build with 2017 rather than 2019—regardless of settings. Hopefully if people run into this as I did, this should save some headaches. Fairly easy work around of just going to the jucer file.


Log in to reply
 

11
Online

1.1k
Users

3.8k
Topics

33.3k
Posts