Launch Crash on OS Sierra

  • No problem, I was perusing different generators and left the computer for minute, came back to a crash report. Yeah... That crash log was mammoth.
    Anyways, I hope you get the standalone fixed soon.
    The vsti (if it behaves) seems more than suitable for now.

    Thanks for the help, and GREAT software.

  • Little question.... Will there be a wavetable with loadable wav files in the future?
    That would be absolutely spoiling us 🙂

    Oh, and why no compressor in effects?

    Anyways... Again, Amazing work... I'm flawed by the features already there.

  • NOPE... This was after loading a few samples creating a multi sample hat drum stack, then playing with the velocity envelope editor while triggering samples with midi controller.


  • administrators

    Wow, you're on fire 🙂

    Normally the sampler is supposed to be the most stable part of HISE so this crash is a little bit more worrysome than in the wavetable synth. Did you use the multimic feature?

  • No... Straight Sampler, Drop Samples, Layout Velocities, Adjust Velocity envelope in gain modulator BOOM!!! Hard crash, No more Reaper on screen, Greeted by crash report! Game over 😞

    I'm now running it through it's paces in Ableton... Seems less temperamental, tho I'm trying to load a SFZ as table and it seems to have frozen on the spinning beach ball of death. 😞

  • Still Getting this in vst using sampler... It occurred when I tried to reopen the vst window.
    Let me know if these help, or not so much.

  • administrators

    Thanks, this is very helpful. I'll take a look tomorrow (the fix should be easy).

  • administrators

    Alright. I've (probably) pushed a fix for this. Can you check if this still occurs (if you can't compile HISE from the source code, let me know, then I'll build it for you).

    BTW, can you send me the SFZ file that's crashing? The SFZ importer is not 100% standard compliant, I just tested it with .sfz files that I created using Chicken Translator.

  • I have no idea how to compile software... Tho at times I wish I could.
    I'm happy to test for you tho, if you e-mail (saves me having to check this site) or post a link I'll give it a go.


  • I've tried building hise, but although I disable the IPP it still throws IPP errors, I then downloaded the IPP package, but I can't for the life of me work out how it's installed. I've spent days now trying to build this thing, so I''m just gonna BUMP ths post till someone can help.

  • administrators

    Can you post the build errors? It should be compilable without IPP, but I don't have a system without IPP installed, so I can't really reproduce a fresh system.

    Otherwise the IPP library comes with a standard installer, which should copy all necessary files into the right place automatically.

  • I can't work out how to export the log from xcode (I'm such a frigging moron with this techie stuff) so I did a screen grab...

  • Could you point me in the IPP installers direction??? I just got a folder with .sh files but when I click them they just open xcode and give me a bunch of text.
    Thanks in advance.

  • administrators

    It was a long time that I installed IPP on OSX, but if there is not a proper installer, I think you have done something wrong. Running shell scripts (what the .sh extension is) was definitely not necessary.

    Did you register at Intel and downloaded the IPP Community Edition (it's a 500MB download)?

    On the other hand, I think I know how to fix your build errors, so you don't need to hassle around with IPP:

    1. Open the Projucer app found in {HISE SOURCE FOLDER}/tools/projucer
    2. Load the standalone project found under {HISE SOURCE FOLDER}/projects/standalone/HISE Standalone.jucer (the procedure is the same for the plugin version found at projects/plugin/HISE.jucer)
    3. Click on Xcode (MacOSX) in the left pane.
    4. Remove everything in the Extra Linker Flags field (these are library files that are installed with IPP).
    5. Click on Save Project and open in IDE
    6. Xcode should open with the project and you should be able to proceed as known.

    Let me know if this works.

  • I think I sorted it??? I installed ipp (I totally missed the drop down for the download and got the linux version) So I installed and built... But when I check the version in the plugin it still says Build version 649?? I'm hoping this is just a build oversight, and it's only changed on official builds. Also, no 16 outputs version in the betas?
    I think it's good, vst seems stable on my system now 🙂
    Cheers again for this amazing work, and putting up with a programming noob.

  • OK... So I loaded some samples, selected them, tried to delete and got a crash again...

  • administrators

    Thanks, I'll check this out. Are you in the Sampler workspace or in the main workspace? I realized there are some stability issues in the Sampler Workspace that could lead to crashes like this.

  • I was deleting them from within a sampler patch window in the main view... I selected the sample velocity ranges and deleted from there (the velocity squares).
    I either used a right click function on the ranges (If there is one?) or just hit the delete key... Sorry can't remember which process I used now.

  • administrators

    I've just committed a fix for this. Please check if the crash still occurs (I could not reproduce it, but I think I know what was causing the crash thanks to your crash report).

Log in to reply





Looks like your connection to Forum was lost, please wait while we try to reconnect.