Problems with Arpeggiator and Note Length at value 100



  • Hi everyone,

    I have a weird problem with arpeggiators. When I set the note Length from 0 to 99, there is no issues happening. But as soon as the note length is set to 100, the sample will play at its full length but the arpeggiator will stop playing notes in the sequence. as soon as the note length is nudged down to 99, the sample will be cut to let the other note in the sequence play without issue. The problem with this though is that it creates an awkward click in the sample and won't play the one-shot as intended.

    As anyone else had the same problem ?



  • Also, I tried to put the SliderPack Max value to 99, but because it is attached to an Arpeggiator, it won't let me change the Max Value and will always be set to 100.

    If there was a way to max it out to 99 that would be perfect.



  • I've noticed this too.

    The trick to setting the sliderpack max to 99 is to create knobs which are linked to the sliderpack values. You can set the knob maximums to 99 and use them to control the sliderpack which is linked to the arpeggiator.



  • @Lunacy-Audio Why don't you just change the max value of the scriptSliderpack?



  • @ustk When a sliderpack is linked to an arpeggiator, HISE prevents you from changing the maximum value of the sliderpack in both the IDE and scripting. If you try to change any of the default properties, it will automatically set them back to the defaults.

    Unable to change sliderpack props.gif

    It seems like this may have been intentional in order to prevent the user from accidentally setting the arp values to something other than what they should be. However, it becomes an issue when the arp values themselves can cause bugs, like the issue @Alex-Paradis described above.


Log in to reply
 

5
Online

704
Users

2.8k
Topics

23.9k
Posts