Logic FX plugin problem



  • hello, i have a question.
    I created a fx plugin for mac and windows. it works on all software except logic (mac). recently i changed the code plugin and bundle identifier code. logic detects the plugin but cannot open it and there is no error message. the problem could come from what in your opinion? I have tried to export several times to Au nothing is doing there while the vst and the au in ableton works.
    Thank you 🙂



  • Does the plugin pass AU validation? Did you checked Plugin Manager?
    If plugin is already validated, you might clear audio unit cache (since you've changed bundle identifier).

    Check this guide: https://www.noiseash.com/knowledge-base/i-cant-see-my-plugins-in-logic-pro-x/



  • @orange thanks u

    it appears well in the list but does not open. I cleared the cache but it's the same 😞



  • @yall Have you tried re-validating in Plugin Manager?



  • @orange Hello. so, in faur c was a stupid thing. I had not checked the box "mono fx support" in hise. when i opened my plugin in logic it was only displayed on stereo tracks. so everything was just a simple mistake. However, I observe a big slowdown and lack of fluidity of the plugin on Mac and that on the other hand I do not understand. there is no slowdown on previous versions of mojave. but from mojave to catalina. the plugin is not fluid at all


Log in to reply
 

6
Online

647
Users

2.6k
Topics

21.4k
Posts