mac :( :( :(



  • Good morning all.
    I come back to you regarding my installation on mac ...
    so I managed to compile perfectly hise with xcode 8 (my mac does not take xcode 10)
    however, when exporting a UI plugin, I have the following problems.
    impossible to install xcpretty and rubygem surely because of SSL.
    from my mac terminal, i can't install xcpreety because it can't connect to rubygem. so i have the following error (Could not find a valid gem 'xcpretty' (> = 0), here is why:
    Unable to download data from https://rubygems.org/ - SSL_connect returned = 1 errno = 0 state = SSLv2 / v3 read server hello A: tlsv1 alert protocol version (https://rubygems.org/latest_specs.4.8.gz) )
    anyone have a solution to work around this problem?
    I am completely lost, it's been 4 days that I am blocked and that I lose patience ^^
    I tried with mac 10.9.5 then mac sierra, always the same problem. on the internet I looked for solutions regarding SSl but it totally exceeds me, I would like an ultra simplified explanation if possible.
    thank you for your answers and sorry for my english written with google translation ...



  • I'm really trying hard to remember how I got around this problem 🤔

    Have you tried installing Rubygems manually as instructed below?

    https://rubygems.org/pages/download

    Keep your head up mate... You'll get it sorted in the end ☺


Log in to reply
 

9
Online

601
Users

2.4k
Topics

18.4k
Posts