HISE 2.0.0 - Missing Autocomplete and connect wizard?



  • Hi there,
    I'm fairly new to HISE and trying some first steps. To get an initial grip I wanted to redo the "HISE in 5 Minutes" video with my own samples and noticed the mentioned problems:

    • on the octaveTranspose Button, adding the dot, no Autocomplete pops up - by pressing Escape it also doesn't do anything.
      There is however Autocomplete on Keywords (like "Message") but not on any other components like knobs
    • Connect Wizard for the Knob is nowhere - in the Docs it should be there since Build 631, I'm on build 650

    Additionally, when I type in everything, "getValue()" appears to be an unknown function.

    I've stopped so far since I am not sure if the Video is too outdated, or if it's a bug etc.

    Thanks in advance!



  • Sounds like the video is outdated. Your best bet is to build HISE from source to get all of the most recent features.



  • @d-healey
    Alright, thanks.

    Since the Tutorials are Offline mainly as well (at least through the official website) - are there already some "0 to Hero" style Tutorials around? (Granted knowledge of Samplers and the programming language? I'm a coder and developed some Kontakt instruments before)



  • I have tutorials on my YouTube channel and more on my Patreon page where I add new tutorials each month.



  • @d-healey
    Thank you, yeah, I saw yours already (only skipped through mainly). Also trying to look through some sources to see how and where.

    Thanks again for the quick responses!


Log in to reply
 

9
Online

553
Users

2.1k
Topics

16.4k
Posts