[SOLVED] I've messed up my exporting process...



  • I didn't perform an export for long, so I don't remember what I did to mess up the process...

    When I export a plugin, it's only building the last format I used, let me explain from the beginning:

    1. If I empty the binaries directory, the build sequence complains not to find a proper Xcode project (and don't create it automatically). So for that, I need to run manually the jucer file. Here's the line that is related to the problem although I don't know what to do in order to fix that:
    /Users/greg/Documents/_PROGRAMMING/BlueMouth/Binaries/batchCompileOSX: line 2:
    /Users/greg/Documents/_PROGRAMMING/_HISE/tools/Projucer/Projucer.app/Contents/MacOS/Projucer: Permission denied
    
    1. Once the previous part is working, I export my first plugin. When I try to export to another format, the second problem shows up. Let say the first export was VST, then all the following export will be VST, no matter I select AU or AAX... 🤔

    2. (not a big deal this one) When exporting AAX, VST is automatically exported at the same time. It might be normal behaviour though...

    The Hise path is set correctly
    Thanks! 🙂



  • I realized that it's because of the Projucer access issue that the following builds are always the same, given the jucer can't be rebuilt...
    So why this "Permission denied" issue?



  • Ok, the Projucer.app was corrupted, so I downloaded the last version...


Log in to reply
 

8
Online

546
Users

2.0k
Topics

16.0k
Posts