samples not working after instalation



  • hello everyone! 🙂
    I'm new to hise but I managed to design a plugin and inside hise it's working (thanks to the lovely information found on this forum). The problem is when I export into vsti and try to open it in cubase. The installer asks for the h1 one file which i previously exported and once i choose it, it says that the files are imported successfully - but there is no sound when i play the midi controller or click on the keyboard. I've read about the problems with samplemaps and i think I've tried most of the things people recommended here on the forum but it still doesn't work. I don't code but i can try some simple stuff if necessary 🙂
    I have hise 2.0 built on windows 10 and visual studio 2017



  • @markmrak One you've pointed it to the samples you have to restart the plugin (remove it from the track and re-add it).



  • @d-healey I tried that and it's still not working, I'm getting some warnings during the compiling:

    c:\users\kompa\desktop\hise\hise-2.0.0\hi_zstd\hi_zstd\zstddictionaries_impl.h(109): warning C4389: '!=': signed/unsign
    ed mismatch (compiling source file ..\..\JuceLibraryCode\include_hi_zstd_3.cpp) [C:\Users\kompa\Desktop\HorPlugin\Binar
    ies\Builds\VisualStudio2017\babayaga1_SharedCode.vcxproj]
    c:\users\kompa\desktop\hise\hise-2.0.0\hi_zstd\zstd\dictbuilder\zdict.c(79): warning C4505: 'ZDICT_clockSpan': unrefere
    nced local function has been removed (compiling source file ..\..\JuceLibraryCode\include_hi_zstd_3.cpp) [C:\Users\komp
    a\Desktop\HorPlugin\Binaries\Builds\VisualStudio2017\babayaga1_SharedCode.vcxproj]
    

    could this be the problem?



  • @d-healey I compiled the vsti again and now it works after i restart the plugin..could it be because I was transfering the plugin to the vst3 folder? Now that i had all the files in the vst plugins folder it worked...anyway thank you (and also for the great video tutorials)! 🙂


Log in to reply
 

20
Online

540
Users

2.0k
Topics

15.9k
Posts