Compile HISE Problems



  • Hi again guys. Sorry for all the noob questions. Really struggling here.

    I've made a rough test reverb plugin inside of HISE and I'm trying to export it out but I get the error 'HISE path not set'

    I've tried to follow all the instructions on how to compile HISE that are on here:... https://github.com/christophhart/HISE/

    ...but nothing is happening. I get to this part..

    "Click on "Save Project and open in IDE" to load the project in XCode / Visual Studio"

    ..and did that, (I think) but then it says...

    "Hit compile and wait..."

    I can't see anywhere that has a compile button. Does in mean in Projucer, or in HISE itself?

    Really going round in circles now. Any help would be very much appreciated!

    I have the Intel Performance Primitives installed and have folders for the ASIO SDK and VST SDK but not sure what to do with them.

    I'm on mac by the way if that helps.

    Thanks in advance.



  • @SteveRiggs you need to set the path under preferences. Choose the source folder matching the complied versio of Hise you are using.

    Screen Shot 2019-04-26 at 12.33.00 PM.png
    I think Christoph s tutorial is about compiling hise from source, not compiling a plugin itself.

    Btw try first a simple sinewave VST AU export.



  • @hisefilo Thanks mate. I'm being really dumb here. I'm not sure my HISE version is compiled, or how to do that, or where the source code is, or which folder I should be pointing it too. I need a holiday lol.

    I now know how my clients feel when I'm trying to teach them Ableton 😂



  • @SteveRiggs On https://github.com/christophhart/HISE/releases/ you'll see here 2 links (.pkg and .zip) one is the compiled version (.app ready to launch) and the other one is the source.

    Get both.
    Use the compiled version to create your VSTs, and the source to be pointed on preferences (dont forget to place VST sdks inside source /tools/SDK

    Screen Shot 2019-04-26 at 12.49.42 PM.png



  • @hisefilo Excellent. I think thats done it! Thanks mate.

    Ok so I've just done "Export as FX Plugin" and it said "check sample references - do you want to validate all sample references" .. so I clicked ok and chose export format at VST + AU

    It then says, "batch file already found - do you want to rewrite the batch file for the compile process" so clicked ok.

    a text window pops up and runs through this...

    Screen Shot 2019-04-26 at 17.40.05.png

    .. and that should be it? Not sure where to find my exported vst and au files now though 😂

    Almost there! Thanks for your patience.



  • @SteveRiggs that exceeds my basic experience. AFAIK you need xcpretty ('gem install xcpretty' on terminal) I remember I faced the same, and also Xcode command line tools is needed. I guess those were installed on Xcode install in my mac, so it just worked.

    AFAIK Is good to rebuild batch files when you are asked for. Those files were paced there by the compiler on last compilation.



  • @hisefilo Man this is hard work 😵

    Ok, I installed xcpretty in terminal, i think that worked... and also tried installing command line tools, but it said that was already installed.

    I now get this message when trying to export vst and au from HISE. It says I need xcodebuild? Any ideas?

    Screen Shot 2019-04-26 at 18.11.53.png



  • @SteveRiggs Can't remember what I've done. I guess I googled.
    xcode-select is not finding the proper folder for command line tools since Hise invoques xcode build to compile. A workaround is to open the projucer project generated on /Binaries and compile it manually on Xcode

    http://osxdaily.com/2014/02/12/install-command-line-tools-mac-os-x/



  • I remember I spent like 2 days to get my first plugin running 🙂 don't panic



  • @SteveRiggs sudo xcode-select --switch /Applications/Xcode.app/Contents/Developer if you are brave 🙂



  • @hisefilo I'll try it! what do I do? add sudo xcode-select --switch into terminal? As long as it doesnt kill my mac

    I had a look in the applications folder and theres no xcode.app in there :s



  • @SteveRiggs Mhm so you'll need to install Xcode first. Don't know why but was already there on my Mac.



  • @hisefilo Ah crap! 😭

    Screen Shot 2019-04-26 at 18.36.07.png



  • @SteveRiggs I'm still on high sierra becuase the GUI maker I use for my kontakt libraries only supports this one. I dont think it works on anything higher. I'm half way through building a library for a client in there at the moment... and also, the last time I tried to do the update, my mac froze for about 5 hours on a black screen. I eventually turned it off but now it doesnt shut down properly and i have to hold the power button down every time. Not sure what to do now cus if I corrupt the install I wont know how to get it back working again. Got a full diary at the moment for engineering jobs in the studio and also building plugins for clients and loads of other projects so it could be suicide for business if I run into problems with any of it. Brains fried now 😭



  • @SteveRiggs No need to update our macos. Just use a previous version of Xcode. In fact Im using Xcode 8. find the one that's supported on high sierra. Im a step behind, still on Sierra



  • @hisefilo Amazing. Cheers dude! Downloading xcode 8 now. Fingers crossed this works!!!



  • @hisefilo Ok so I finally got xcode downloaded and installed and I tried the export again from HISE but I'm still getting the same error message below... And its strangely still not showing up in the applications folder ☹

    Screen Shot 2019-04-26 at 21.54.29.png



  • @hisefilo I've tried some googling and did the " sudo xcode-select -s /Applications/Xcode.app/Contents/Developer " in terminal also, but its saying its an invalid developer directory ☹

    Screen Shot 2019-04-26 at 22.43.58.png



  • @hisefilo It almost worked that time! Got right to the end of the build and then failed. It even made the vst file. Progress, but still no cigar! I'll keep going....

    Screen Shot 2019-04-26 at 23.11.03.png



  • @SteveRiggs you are almost there! there's a checkbox on Hise to that I think will fix that.
    Screen Shot 2019-04-26 at 7.21.12 PM.png


Log in to reply
 

4
Online

453
Users

1.5k
Topics

11.3k
Posts