IPP Missing in Plugin Export

  • @Zorpley Did you set that path in the .jucer screenshot above?

  • This is a relevant thread I found on using ipp from the command line: https://community.intel.com/t5/Intel-Integrated-Performance/Is-it-possible-to-use-IPP-by-command-line-parameter-to-compiler/td-p/1109403

    The info linked there looks like a complete nightmare to set up.

    What I don't understand is why I'm the only one with this issue. Surely others have installed HISE recently? How does everyone else have ipp set up so it can just be included without going through that Visual Studio configuration dialog?

  • @d-healey No, it was there, correctly, by default. The problem is that pointing at ipp.h doesn't actually work on its own. Apparently you also need a VS environment where you can go to this configuration dialog and enable it.


    Actually, I wonder what happens if I install ipp without the Visual Studio integration.

  • @Zorpley said in IPP Missing in Plugin Export:

    The problem is that pointing at ipp.h doesn't actually work on its own. Apparently you also need a VS environment where you can go to this configuration dialog and enable it.

    I've never touched that. It's weird that you had that path by default. Did you change it in the HISE jucer project before you built HISE?

  • Ok I was getting confused with MacOS. Under Visual Studio >> Release there should be no IPP paths at all. Those boxes should be empty, except for the semi-colon. It's strange that yours isn't, I wonder if this is something that VS did.

  • This post is deleted!

  • I did not change anything regarding ipp paths when opening the HISE standalone .jucer. I did however have to enable IPP using the Visual Studio properties dialog box.

  • @Zorpley Yeah I guess it must be something to do with the changes you made in VS studio that has added those paths to the jucer file. Try deleting the path since it should be empty (leave the semi-colon).

  • Without setting that option in Visual Studio, HISE standalone itself will not build at all.

    If I delete that path from the project .jucer and leave only the semicolon it does not appear to make a difference. ipp.h still cannot be found, because that GUI option must be set in VS.

    Where has everyone else been getting ipp from? How is it set up? Someone mentioned that the 2019 ipp worked, but intel has made legacy versions completely impossible to obtain as far as I can tell.

  • @Zorpley

    intel has made legacy versions completely impossible to obtain as far as I can tell.

    Yeah Intel keep screwing things up with their installers. I haven't reinstalled IPP since 2019 so I don't know exactly what to do with the current setup. But as far as I'm aware no-one has mentioned having to change GUI options in Visual Studio.

  • Any chance you could share your copy of the library? I've been trying to get this to work for most of today and it's driving me a little bonkers.

  • @Zorpley Not really, there's about 4GB of "intel" files spread across various folders, I don't know which you would need or even if just sending the files would work. I would think the installer also includes some kind of system integration. Just build without IPP for now (the convolution will still work) and wait for someone who's already installed it to chip in with the correct instructions.

  • @Zorpley I'm getting the same error, you're not alone. No solution so far either. 😖

  • Adding these paths and enabling IPP in the project properties in Visual Studio should solve the issue:

    (The paths might be different on your system, use your file explorer to check).


  • You also need to add these lines (including the double quotes) to the extra linker flags section under the Visual Studio 2017 heading:

    "C:\Program Files (x86)\Intel\oneAPI\ipp\latest\lib\intel64\ippi.lib"
    "C:\Program Files (x86)\Intel\oneAPI\ipp\latest\lib\intel64\ipps.lib"
    "C:\Program Files (x86)\Intel\oneAPI\ipp\latest\lib\intel64\ippvm.lib"

  • Also set Use IPP Library to Yes (Default Linking).


  • Thanks David! Using those settings, building HISE itself with IPP works fine, without needing to modify anything in VS. However plugin export still runs into some new ipp-related issues.


    I tried poking around, but I just end up following back a bunch of #includes in different files with no real idea what I'm doing.

    If I also enable IPP in the Visual Studio project as above, the plugin compiles, but it does not load in any DAW. Reaper does not even display it in the plugin list, and FL studio shows it as having an "error" in the plugin list. Disabling IPP and building again results in a vst that loads fine.

  • @Zorpley Yeah I haven't solved it either

  • Huge thank you to @DanH for having the foresight to save the old IPP installers (I was kicking myself for not doing the same). I can confirm that using IPP from the link in his post here works fine.

    Here is the direct link to the correct IPP version.

    Here is a backup link in case the Dropbox one stops working for whatever reason.

    This kind of nonsense in software development drives me nuts. If Intel had just kept the old links up we could have avoided wasting our collective time.

  • @Zorpley I think I like the new installer better, though I'm not sure what it changes that's incompatible with HISE, I don't know the smaller details.

    I think the developer will get around to trying to fix it, because third-party downloads of old software are unreliable and sometimes pretty sketchy. It's unsustainable to continue relying on something like that. Of course scriptnode seems to come first for now, and that looks like a pretty cool feature, so...

Log in to reply