Multichannel Routing issue



  • Debugging in Visual Studio. I'm getting somewhere I think.
    PluginHost throws an exception on jassertfalse;

    #ifndef MODULATORSAMPLER_H_INCLUDED
    #define MODULATORSAMPLER_H_INCLUDED
    
    namespace hise { using namespace juce;
    
    class SampleEditHandler;
    
    /** The main sampler class.
    *	@ingroup sampler
    *
    *	A ModulatorSampler is a synthesiser which allows playback of samples.
    *
    *	Features:
    *
    *	- Disk Streaming with fast MemoryMappedFile reading
    *	- Looping with crossfades & sample start modulation
    *	- Round-Robin groups
    *	- Resampling (using linear interpolation for now, but can be extended to a complexer algorithm)
    *	- Application-wide sample pool with reference counting to ensure minimal memory usage.
    *	- Different playback modes (pitch tracking / one shot, etc.)
    *
    *	Current limitations:
    *
    *	- supported file format is stereo wave.
    */
    class ModulatorSampler: public ModulatorSynth,
    						public ExternalFileProcessor,
    						public LookupTableProcessor
    {
    public:
    
    	/** A small helper tool that iterates over the sound array in a thread-safe way.
    	*
    	*/
    	class SoundIterator
    	{
    	public:
    
    		using SharedPointer = ReferenceCountedObjectPtr<ModulatorSamplerSound>;
    
    		/** This iterates over all sounds and locks the sound lock if desired. */
    		SoundIterator(ModulatorSampler* s_, bool lock_=true):
    			s(s_),
    			lock(lock_)
    		{
    			if (s->getNumSounds() == 0)
    			{
    				lock = false;
    			}
    			else
    			{
    				if (lock)
    				{
    					lock = s->getMainController()->getSampleManager().getSamplerSoundLock().tryEnter();
    
    					if (!lock)
    						jassertfalse;
    
    					//s->getMainController()->getSampleManager().getSamplerSoundLock().enter();
    				}
    					
    			}
    		}
    

    Once I skip past that breakpoint, the debug version of the plugin loads



  • @staiff

    thanks for they nice Video staiff.



  • thanks.

    if you encounter an error (or crash) of the plugin =
    in PC : erase/delete the: user/appdata/roaming/you/Pluginfolder and reload it.
    it will ask again the sample location and all will goes ok again 😉

    yes, i know ... boring ... but it works !

    For MAC i don't know but the same thing as appdata/roaming for PC.



  • @staiff thank you so much, this tutorial is very helpful.



  • @staiff That's what I've been doing to get things rolling, but it always crashes the host on restart.
    Do you have any experience debugging? I'm getting a break at jassertfalse; and once I continue, the debug version of the plug loads.


Log in to reply
 

10
Online

517
Users

1.9k
Topics

14.7k
Posts